Monday, February 04, 2008

Blogger Posts Keep Disappearing? Turn your compose mode off...

Blogger has this weird thing whereby if you try and go back to edit a post you've already published -- especially one that contains Amazon iframe code or YouTube or other video code -- it'll disappear as soon as you open it to edit it!

The way to get around this is to go to Settings link tab, click Basic and go down to where it says "Show compose mode for all your blogs?" as pictured here.

Turn that question to "No" and click "Save Settings" -- and you'll have your blog post back to edit nicely.

If you're not a coder and not used to stuff outside of the "What You See is What You Get" or WYSIWYG mode -- things might look a little tricky with all that HTML code and stuff.

But just keep clicking the "Preview" mode Blogger gives you to see if it looks okay, play around, Google for code questions and you'll be fine.


Bonnie Calhoun said...

Have you put this question up on the Blogger Help group? I don't see this as a widepsread issue. It may be confined to the server you're on. I 'll have it looked at!

Glen said...

I thought it was just me but I experience this same problem occasionally with Wordpress. I have gotten to the point that when I need to include Amazon or YouTube code in a post I compose the article in HTML mode. It has to be a problem with WYSIWYG mode.

Paula Neal Mooney said...

Hey Bonnie
Nope, I didn't put it up on the help group. But thanks for having it looked at!

You're right, this happens on WordPress too.

That used to drive me crazy till I Googled the problem and learned to turn off the "Visual Editor" mode over in WordPress when I need to stick YouTube code or Amazon iFrame code in a post over there, too.

Thanks for reminding me.

It must be a WYSIWYG issue.

Paula Neal Mooney